Bienvenido a Facturas y Respuestas.

Esperamos que encuentre la respuesta a su pregunta. Y si no, puede formularla para que los expertos de la comunidad la respondan.

Preguntar

Este blog es creado y administrado por:

Copyright - 2020

+1 voto
por en Preguntas Tecnicas

Utlizando el software SoapUi, al enviar la factura  a la DIAN según el nuevo esquema de validación previa, me responde que el NIT 1234567 no autorizado a enviar documentos para emisor con NIT 123456, y observo que el primer nit (1234567) tiene como último caracter el dígito de verificación porque así figura en el certificado de la firma, y en el segundo nit (123456)  es sin el dígito pues creo que en el  XMl va así

4 Respuestas

0 votos
por
Buen día, estoy realizando este proyecto para mi empresa y me ha presentado el mismo mensaje de error, usted podría por favor darme alguna luz sobre como poder resolverlo, gracias.
por
Revisa que no quede espacios en blanco en el XML, cuando se muestran los nits tanto del que factura como del adquiriente, o sea cerrar las etiqueta para que salgan espacios en blanco
por
Buenos días, tenia el mismo problema y era porque no me había registrado en el portal de la Dian para validación previa. En caso de que tampoco lo hayas hecho puedes hacerlo desde la opción "Transaccional " y luego"Habilitación", al registrarte te darán la resolución para la validación previa y un nuevo Webservice para las pruebas.
por
Yo ya hice el registro y estoy testeando el servicio mandandole facturas de prueba pero me responde un Status 415 "HTTP response '415: Cannot process the message because the content type 'text/xml; charset=UTF-8' was not the expected type 'application/soap+xml; charset=utf-8'.' when communicating with https://vpfe-hab.dian.gov.co/WcfDianCustomerServices.svc"

Me podrias dar una guia de como estas haciendo el consumo y el proceso de autenticacion por favor
por
Buenas noches.  Tenía el mismo problema, sustituí content type 'text/xml; charset=UTF-8' por 'content-type': 'application/soap+xml; charset=UTF-8', ya no me arroja el error 415, ahora me da un error 400, pero al menos es un avance. Espero te sea útil.
por
Hola, el problema era en la forma en que estaba haciendo el consumo, por eso me salia el error pero ya logre solucionar el error, en este caso valida la forma en que estas consumiendo el WS, basate en la pagina 795 de la guía tecnica "Anexo: Herramienta para el consumo de Web Services"
por
Has podido resolver esto? Estoy necesitando tambien la autenticación, si me puedes ayudar te lo agradecería enormemente.
por
Hola como estas haciendo la autenticacion y que problema estas teniendo exactamente
0 votos
por
Buen día estoy realizando el proceso para mi empresa pero tengo el mismo problema el web service de la DIAN me responde "NIT 11111111 no autorizado a enviar documentos para emisor con NIT XXXX" (nit de mi empresa), estoy en pruebas de habilitación usando el mismo certificado digital con el que firmaba las facturas en la version 1 (UBL 2.0) pero no entiendo a que se deba este problema si pueden darme una pista de cual sea el problema, les agradeceré enormemente
por
Hola, buen dia, estoy haciendo pruebas con la DIAN igualmente, me salio ese anuncio, y cambiamos de firma por la de ANDES y conecto de una vez....
Ahora desde ayer voy a iniciar pruebas para terminarlas y me sale  otra vez el mismo mensaje, esto es una pesadilla...
Si lo pudiste resolver o encontrar cual es el problema puedes comentarme por favor...
Estaré super atento. Gracias.
0 votos
por
Este error es comun cuando del lado de la DIAN tienen algo mal en tu registro, deberas levantar PQSR y ostigarlos hasta que te hagan caso. A mi me demoraron 2 meses en corregir ese detalle.
por
Hola buen dia, pudiste dar con que esta mal el registro?
Ya me estoy desesperando porq no recibo sino presión, y se q no es mio el problema...
Ya lo hice con un cliente y no tuve problema este es el segundo y me esta generando muchos problemas....
Gracias, estaré atento a tu mensaje...
por
Aun continuas obteniendo ese mismo error de "NIT 1234567 no autorizado a enviar documentos para emisor con NIT 123456" ???....

Solo para salir de dudas, pegame link hacia tu XML que generas y mandas en el SOAP Request.
por
Si, aun. Pero sabes que es lo mas extraño, que yo el martes que inicie pruebas conecte con ellos y envié facturas, el miercoles tambien, e igual el jueves, pero ya el viernes no, me salio ese msn, te adjunto imagenes y el pdf y el xml. Gracias

https://drive.google.com/drive/folders/13Kpv8Ce0IR7UDHs9ocnXN_cBPcMq1qoQ?usp=sharing
por
Es porque te faltan etiquetas en tu XML
+1 voto
por
Buenas tardes.....por favor para este error verificar el WSDL al cual se esta direccionando el envío del documento. Tener en cuenta que existen dos WSDL.

https://vpfe-hab.dian.gov.co/WcfDianCustomerServices.svc?wsdl  (pruebas y habilitación)

https://vpfe.dian.gov.co/WcfDianCustomerServices.svc?wsdl   (productivo)
por
Hola, al consumir el webservice , me retorna un error de que se deben de incluir las credenciales. Cuales deben de ser ?
por hace
Generalmente este es el problema y se soluciona usando la URL correcta para conectar al web service

Preguntas relacionadas

...